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Preface

This document is designed to give you a brief overview on how to get started in Snap-Master. For more

information on using Snap-Master, check out the online help file (especially the Tutorials section) and the Snap-
Master User's Manual.

Set aside approximately 30 to 60 minutes to check out Snap-Master and its capabilities. In that short time, you will
see how easy it isto get datainto your computer and on your screen with Snap-Master.






Quick Start Guide

Page 1

1. Creating Your First Instrument

Creating a New
Instrument

This tutorial illustrates the basic tasks for creating an instrument in Snap-Master. We
will create a simple instrument consisting of the A/D Demo and a Display (these
elements are used in most of the tutorials).

The descriptions given in this section provide step-by-step details, which are helpful for
newcomers to Snap-Master. Later tutorials contain less detail in regard to the general
user interface.

fl C:\SMADEFUSERAEXAMPLET.ING  [i[=] ES

Sample Instrument

1. If any instruments are open in the workspace, close them using the File menu, Close
Instrument command.

2. If the Toolbox containing the element icons is not visible on the left side of the Snap-
Master workspace, select the View menu, Toolbox command.

This places the Toolbox containing the available element icons in Snap-Master.
When the Toolbox is open, a check mark appears next to the Toolbox menu item.

3. Create a new instrument with the button or select the File menu, New
Instrument command in the Snap-Master workspace.

This opens a clean, untitled instrument window in the workspace.
4. Type Sample Instrument in the Comment Field.

The Comment Field is a place where you can type information about the instrument.
To type comments, use the mouse to position the arrow cursor over this field, then
click the left mouse button. A flashing vertical bar will appear in the comment field.
When this vertical bar is present, you can type the information in to the comment
field.

Instrument Settings...
C
[F MNone " One Line  *Two Line:

Select Color... | Select Picture... |
Picture Location:  Upper Left  Centered
 Tiled ¢ Clear Picture

[ Status Messages

oK I Cancel | Help |

If the Comment Field is not visible, double click in the instrument window or select

the button in the Command Bar to open the Instrument Settings dialog. Select
the Two Line Option in the Title group, then press the OK button.
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Placing and
Connecting the
Elements

1. Place the A/D Demo element

5. Save the instrument as EXAMPLE1 with the I.%I button or select the File menu,
Save Instrument As command.

File Save As...

File Name: Directories:

l—e,am‘,.etim c\smdefuser
0917ip01.ins - Hen
analysis. ins

block.ins_ %s:l':alu:el

Cancel

4l

Hetwork ..

faex1_ok.ins
fftins
filters_ins d

File Type: Drives:
Instrument =l [=e hady =l

Because this is the first time the instrument is being saved, the File Save As dialog
box appears. The File Name field is highlighted, so al we have to do is type
EXAMPLEL.

It is not necessary to type the .INS extension in the file name because Snap-Master
will automatically add it for you. It is not recommended that you specify an
extension other than .INS. The default directory for your instruments is the
DEFUSER subdirectory, which is what we will use for this example.

NOTE: It is important to save your files frequently so that no information is lost.
The tutorials are designed to remind you to save the data at the end of each section.

Position the mouse pointer over the A/D Board icon in the Toolbox. Click on the
left mouse button. If you own the Data Acquisition module, a pop-up menu might
appear with a list of installed A/D Board drivers. If it does, select the A/D Demo
option from the list. A check mark indicates which driver is currently selected.

Position the mouse pointer on the A/D board, then click and hold the left mouse
button. When you move the mouse, the cursor will change to the outline of the A/D
Board. Drag the A/D Board cursor from the Toolbox until it is over the instrument
window (underneath the comment field), then release the mouse button. The A/D
Demo element icon should appear in the instrument window.

Notice that when you place the A/D Demo element in the instrument, it is assigned
the element letter “A”. This letter is used by Snap-Master to distinguish the
channels from each element because no two elements can have the same element
letter. For example, channel O will be referred to as channel AO by all elements in
the instrument.

Check to make sure that the text underneath the icon says "[A] A/D Demo". If it
does not, press the DEL key to delete the element from the instrument. Return to the
beginning of this step, remembering to select the A/D Demo element from the pop-
up menu on the A/D element icon in the Toolbox.
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Running the
Instrument

in the instrument window.

2. Place the Display element

Position the Display element to the right of the A/D Demo element. Follow the
same instructions given for the A/D Demo element. Because there is only one
Display element, no pop-up menu will appear when clicking once on the element in
the Toolbox.

3. Activate Pipe Mode with the 1"1 button or select the Element menu, Pipe Mode
command.

4. Connect the A/D Demo element to the Display element.

For this data pipe, the A/D Demo is the source element, and the Display is the
destination element. Therefore, we will connect from the A/D Demo to the Display.

Position the Ql mouse pointer over the A/D Demo element icon, then click the

left mouse button. The mouse pointer changes to % with the arrow pointing

down and to the left. As you move the cursor towards the Display element, a data
pipe connected to the A/D Demo element follows the cursor movement. Position the
mouse pointer over the Display element icon, then click the left mouse button. A
data pipe appears between the elements, with the data pipe arrow pointing from the
A/D Demo to the Display, indicating the flow of data.

5. Turn off Pipe Mode with the 1"1 button or select the Element menu, Pipe Mode
command.

6. Save the instrument with the I.%I button or select the File menu, Save Instrument
command.

When you save the file this time, Snap-Master remembers the file name you
specified previously and updates the file.

Before we run the instrument, let’s make sure the Auto Layout function is set up to
create a new plot for each channel.

1. Double click on the Display element to open the Display window.

If there are four plots (one for each channel from the A/D Demo) in the window,
you can skip step 2.
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2. Select the Options menu, Default Settings command to open the Default Settings

dialog.
Display Defaults. ..
- Auto Layout .~ Options
W iiinl ¥ Command Bar
= Dne Channel Per Plot [V Status Bar
" Dverplot Same Element Letter ™ Scroll Bar
" Overplot Same Channel Number ¥ Auto Retrace
" Overplot Channels With Same Units ™ Apply Defaults For New Plots:
Overplot: [ Use Multiple Y-Axis ~Retrace Mode
™ Warn If Different Units @ Buifer Retrace
Max # Channels: |1 " Full Retrace
I” Delete All Plots Before Auto Layout | piot Technigue |
I Confim Delete Before Auto Layout € All Points
Cursors: [ Select All S dary Channels & Automatic
0K I Cancel | Help |

Make sure the On check box is on, the One Channel Per Plot setting is selected, and the
Delete All Plots Before Auto Layout check box is turned on. When you are done, press

the OK button. If four plots do not appear select the Options menu Auto Layout
command.

3. Press the m button or the Start! menu command.
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That's all thereisto it! Using afew simple steps, you can display data from any element
that outputs data. Of course, it is possible to configure the elements to perform more
specific tasks, but even that is not difficult.

When you are done looking at the data, press the @ button or the Stop menu
command.
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2. Using The IndustrialSQL In Element

Building the
Instrument

Connecting to
the
IndustrialSQL
Server
Database

This tutorial discusses how to access data from and Industrial SQL Server database.
Before continuing the tutorial, make sure that the Industrial SQL Server is running and
that you have the proper access rights to the database.

i —a

[&] InduztrialSAL In [E] |:|I-§u,I

1. Create a new instrument with the button or sdect the File menu, New
Instrument command in the Snap-Master workspace.

2. Place the Industrial SQL 1n and Display elements in the instrument.

3. Activate Pipe Mode with the 1"1 button or select the Element menu, Pipe Mode
command.

4. Connect the Industrial SQL In element to the Display element.

5. Turn off Pipe Mode with the 1"1 button or select the Element menu, Pipe Mode
command.

6. Save the instrument with the I.%I button or select the File menu, Save Instrument As
command. Save the instrument as SQLIN.

1. Open the Industrial SQL In Settings by double clicking on the element.

2. Login to the database using the appropriate Server, Database, Username, and
Password entries.

If this is the first time you are connecting to this server, you are asked to verify the
ODBC settings. You should only enter or modify the Network Address - all other
settings for the ODBC DSN (Data Source Name) are created automatically.
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Activating A

Tag

Running the

Instrument

ndustrialSQL In Settings

Start Time: [11/131567 100000 =] End Time: [11/1371557 100500 v] Fiosohuion: [1000 = ms

‘&l Groups' ‘ ‘&l &nalog Tags' |Achve Tags
@ Wonderworld Fiter: [z

{@ System Objects
1) Public Groups
{ga Al A”Edgg Tag | [ Svstotivelsers
{0 A Discrete Tags | |2 SvsCrtEnCrt
(23 &l Sting Tags i SysDateDay
{3 &l Event Tags SysDateMonth
{3 InTouch Nodes | [ SysDatevsar
{1 System Status Tags |G2 SysEnEnCnt
(g Piivate Giroups SpsErraRate
7] SysFatalErCnt
SyslODriverBytes
5] SpslODiverCPS
SysMinutesFiun

4
. ] [ SvsSpacesit =] | Femeve Curent Tag |

Remove All Tags |

0K I Cancel I Help |

1. Inthe tree view, select the All Analog Tags group and locate the SysMinutesRun tag.
2. Double click on the SysMinutesRun tag to add it to the Active Tags table.

3. Press OK to close the Industrial SQL 1n Settings dialog.

4. Save the instrument with the I.%I button.

[&] Display: Page 1

[ O]
File Edt View Selings Stal Layout. Cusor Helpl
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When you press the button, all of the data is requested from the database

server. There may be a delay before the data is presented on screen depending on the
amount of data requested and the amount of traffic on the network.

To scale the data as shown above, press the Auto Y-Scale @ button.
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3. Investigating The Sample Instruments

Opening an
Instrument

Example
Instruments

There are a number of example instruments that ship with Snap-Master which you can
view and modify. These instruments are a good place to get started when you are
creating your first few instruments to give you an idea of the different ways Snap-Master

can be applied.

1. Return to the Snap-Master workspace window.

2. Press the |

button or select the File menu, Open Instrument command.

Here is a description of some of the example instruments that ship with Snap-Master.
Feel free to browse through the settings of each element by double-clicking the iconsin
the instrument window.

ANALYSISINS

BLOCK.INS

COMPARE.INS

FAEX1_OK.INS

FFT.INS

FILTERS.INS

GAEXAMPL.INS

HISTOGRM.INS

PEAKFIND.INS

PLOTDEMO.INS

REPLAY.INS

[llustrates simple math and statistical functions using the
Anaysis element (part of the Waveform Anayzer /
General Analysis module).

[llustrates using the BLOCK function with statistical
functions in the Analysis element.

Compares the results of the different Differentiation
(Display Page 1) and Integration (Display Page 2) methods
available in the Analysis element.

Shows the results of the FFT element (part of the
Frequency Analysis module) tutorials from the Snap-
Master User's Manual.

Calculates a forward FFT and an inverse FFT based on a
Sawtooth wave from the Wave Generator €lement.

Compares the results of an FIR and IIR filter using the
Analysis element.

Shows the results of the Analysis element tutorials from
the Snap-Master User’s Manual .

Displays a real time histogram output from a sine wave
generated by the A/D Demo element.

Uses Intelligent Processing capabilities in the Analysis
element to find and count the number of peaks in a sine
wave and integrate only between certain peaks.

Displays a number of different plotting types in the Display
element on Display Pages 1 and 2.

Shows how data is brought into an instrument from a data
file using the Disk In element.
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SCOPE.INS

SINEWAVE.INS

STRPCHRT.INS

TANK.INS

TRAPZD.INS

WAVEGEN.INS

YXPLOT.INS

Shows how Snap-Master emulates an oscilloscope’s Y-T
and X-Y plotting modes.

Highlights the different types of Sine waves that the Wave
Generator element can create.

Shows how Snap-Master emulates a Strip-Chart recorder,
along with other plot types on the same Display page.

Shows a custom picture used for the Bar Meter plot type in
the Display element.

Creates a trapezoid waveform with different rise and fall
times using the Wave Generator element.

[llustrates many of the different waveforms that can be
created using the Wave Generator element, including an
arbitrary custom waveform (look at the plot in the lower
right corner of the Display window).

ShowsaY vs. X plot of asignal in the Display element.

For more information and examples on Snap-Master instruments, refer to the User’s
Guide which has a series of tutorials at the end of each chapter. Also check out HEM
Data' s web page at www.hemdata.com for Application Notes on using different Snap-

Master features.



